ioquake3 on raspbian

4 replies [Last post]
arkadi26
Offline
Joined: Apr 2020
Posts:

Hi,
Has someone been able to run a dedicated server on a raspberry pi 3 ? I mean ioquake3 with excessive mod?I'm starting it with this command:

$ ./ioq3ded +set fs_game excessiveplus +set vm_game 0 +set vm_cgame 2 +set vm_ui 2 +exec server.cfg - server excessive

and on the end of the loading I'm getting this message

9034 files in pk3 filesLoading vm file vm/qagame.qvm...File "vm/qagame.qvm" found in "/usr/lib/ioquake3/excessiveplus/z-xp-2_3.pk3"Architecture doesn't have a bytecode compiler, using interpreterqagame loaded in 13298784 bytes on the hunk********************ERROR: VM program counter out of range in OP_JUMP********************----- Server Shutdown (Server crashed: VM program counter out of range in OP_JUMP) -----recursive error after: VM program counter out of range in OP_JUMP

Does this mean that excessiveplus is not supported by raspbian ?
I cannot run OSP mod as well but there is a different story.

Thanks

JIVA
Jiva's picture
Offline
Joined: Jun 2006
Posts:
CZ Czech Republic
Re: ioquake3 on raspbian

raspberry pi 3 operating system raspbian have ioquake3 package
but support mods is less possible , excessiveplus dont work ,

i have the same result
meaby raspberry pi 4

arkadi26
Offline
Joined: Apr 2020
Posts:
Re: ioquake3 on raspbian

Hi,
Thank you for your answer.
I think will be worth to invest into the new RPi and install different system.I have never tried Ubuntu or any simillar on that machine and to run ded Q3 server - only done on Win platforms before.Do you have any experience with the above systems and running on that platforms/systems dedicated q3 server with E+ mod or any other mods ?

Best regards
Arek

JIVA
Jiva's picture
Offline
Joined: Jun 2006
Posts:
CZ Czech Republic
Re: ioquake3 on raspbian

pm message troll alias covid-19 , teach server building

2!S*BEAZT
beazt's picture
Offline
Joined: Apr 2006
Posts:
CZ Czech Republic
Re: ioquake3 on raspbian

Iam successfully running excessive plus dedicated server on rpi 3B+ on raspbian. I never seen that error. Maybe I have newer version of ioquake and this problem is already fixed.
E+ server is running and I can play. Rpi 3B+ is powerful enough to run it. Rpi4 isn’t needed. CPU usage is somewhere about 20% and even RAM has still about 300MB free space.

i was even able to run e+ 1.03 Happy on that rpi. You just have to run q3 client and dont load the e+ mod. Then you will be able to connect to older 1.03 version even if you have installed e+ v2

Gigabyte B450 Aorus Elite | AMD Ryzen 7 2700x @ 4GHz | 16GB DDR4 3000MHz | Sapphire Radeon Rx480 4GB | 250GB SSD (macOS 10.15)+ 500GB SSD (W10P) + 3TB HDD (shared data) | BD-RE | LMP KB-1243-SG + Lenovo Legion 500 RGB